I am having the Vista USB blues

OK it has been three days now and Vista still cannot recognize ANY of my USB drives!  I have installed the latest cumulative update from the KB articles and ran through the steps here to recover the metabase for the drivers.  Has anyone else had this issue?

I am afraid I am going to have to reinstall the OS. 

Any suggestions would be greatly appreciated.

Related Articles:

    Post Footer automatically generated by Add Post Footer Plugin for wordpress.

    About Joe Ocampo

    My personal philosophy is simple: "Have a good strategy that sets the environment for success through the enablement of the whole. Be agile but with a mind towards pragmatism. Delegate to the best qualified individuals, but don’t be afraid to involve yourself in all parts of a job. Treat everyone with respect, humility, and with a genuine pursuit towards excellence." Respected business and technical leader with expertise in directing organization towards effective results driven outcomes. Proven ability to perform and communicate from both technical and business perspectives. Strong technical and business acumen developed through experience, education and training. Provides the ability to utilize technology, harness business intelligence and execute strategically by optimizing systems, tools and process. Passionate about building people, companies and software by containing cost, maximizing operational throughput and capitalize on revenue. Looks to leverage the strengths of individuals and grow the organization to their maximum potential by harnessing the power of their collective whole and deliver results. Co-Founder of LosTechies.com
    This entry was posted in Vista. Bookmark the permalink. Follow any comments here with the RSS feed for this post.

    4 Responses to I am having the Vista USB blues

    1. will says:

      Just a thought… maybe it isn’t the OS? USB add-on cards are pretty cheap. Cheaper than a full system wipe, at least…

    2. Joe Ocampo says:

      I agree…I was thinking it may be the USB port but my mouse printer and keyboard all function fine. In fact my Creative Zen player and Samsung Player work fine as well because they are not using Vista’s USB mass storage driver.

    3. Simon says:

      I had the same issue with the ports on the front of my new Dell. However the USB ports on the back panel work fine.

    4. davetiye says:

      güzel davetiye sözleri ve davetiye modelleri